请问如何使用./kibana-keystore 来配置加密密码?

小白请教各位大神:
      在搭建ELK时,用kibana-keystore 配置了es_pwd来密文加密配置文件,但是启动kibana时提示 如下错误:
[fatal] "es_pwd" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.
 
环境是CentOS 7
安装了elasticsearch、kibana、logstash、x-pack等组件。【6.2.4版本】
在kibana配置 如下:
./kibana-keystore create 
./kibana-keystore add es_pwd
 
配置文件部分:
elasticsearch.password: "${es_pwd}"
 
 拜托各位 大神帮忙,不知是小弟那个地方配置错误还是那个地方安装错误,求帮忙解决。
已邀请:

strglee - 公众号: 每日ELK ,每天分享ELK相关知识

赞同来自:

./kibana-keystore add elasticsearch.username # 存储用户名 
./kibana-keystore add elasticsearch.password # 存储密码
不需要更改kibana.yml文件

yuyaguo

赞同来自:

@strglee 首先很感谢你(大神)的回复,按照你的方法已经成功启动。但是不太理解这种方式,能够解释下吗?
其次我本意不是这样的,我是想通过kibana.yml文件配置如下项
elasticsearch.username:"kibana"
elasticsearch.password:${k_pwd}
再通过命令kibana-keystore创建
./kibana-keystore create
./kibana-keystore add k_pwd
其它没有进行配置,为啥就会报错。难道这个引用关系我理解错了?
[fatal] "es_pwd" setting was not applied. Check for spelling errors and ensure that expected plugins are installed and enabled.
 

要回复问题请先登录注册