启动ES 多个节点 不能形成集群

基本情况:ES版本:1.6.1,安装了head插件; jdk版本:1.7_0_55;操作系统版本:WindowsServer2003
给别人做测试,启动es两个以上的节点不能形成集群
ES的配置如下

启动后报错为
[2016-05-18 10:37:41,593][INFO ][plugins                  ] [node0] loaded [analysis-ik, jdbc-1.4.0.8-93c6cde], sites [bigdesk, head]
[2016-05-18 10:37:41,640][INFO ][env                      ] [node0] using [1] data paths, mounts [[鏂板姞鍗?(D:)]], net usable_space [468.9gb], net total_spac[488.2gb], types [NTFS]
[2016-05-18 10:37:44,406][INFO ][node                     ] [node0] initialized
[2016-05-18 10:37:44,406][INFO ][node                     ] [node0] starting ...

[2016-05-18 10:37:44,593][INFO ][transport                ] [node0] bound_address {inet[/0.0.0.0:9300]}, publish_address {inet[/222.161.229.163:9300]}
[2016-05-18 10:37:44,625][INFO ][discovery.zen.ping.multicast] [node0] multicast failed to start [SocketException[error setting options]], disabling. Consider u
sing IPv4 only (by defining env. variable `ES_USE_IPV4`)
[2016-05-18 10:37:44,640][INFO ][discovery                ] [node0] elasticsearch/7PcduXY4SEaaEGNRo2gFVg
[2016-05-18 10:37:59,671][INFO ][cluster.service          ] [node0] new_master [node0][7PcduXY4SEaaEGNRo2gFVg][server2][inet[/222.161.229.163:9300]]{master=true
}, reason: zen-disco-join (elected_as_master)
[2016-05-18 10:37:59,718][INFO ][gateway                  ] [node0] recovered [0] indices into cluster_state
[2016-05-18 10:37:59,781][INFO ][http                     ] [node0] bound_address {inet[/0.0.0.0:9200]}, publish_address {inet[/222.161.229.163:9200]}
[2016-05-18 10:37:59,781][INFO ][node                     ] [node0] started
 
 
已邀请:

helloes

赞同来自: xiaohei

貌似win server 2003没有启用多播?
 
解决办法:
1、参考(v=ws.10).aspx[/url]


打开“网络负载平衡管理器”。(要打开“网络负载平衡管理器”,请打开“命令提示符”。在命令窗口中键入 NLBMgr,然后按 Enter。 )

如果“网络负载平衡管理器”尚未列出群集,请连接到群集。

右键单击群集,然后单击“群集属性”。

在“群集参数”选项卡上的“群集操作模式”中,选择“多播”。如果合适,还可以通过单击“IGMP 多播”复选框,启用 Internet 组管理协议 (IGMP) 支持。


 
2、改用单播
discovery.zen.ping.multicast.enabled: false 
discovery.zen.ping.unicast.hosts: ["host1", "host2:port"]

dlwang - 爱生活,爱技术

赞同来自:

哥们,elasticsearch.cluster你是否配置的相同?

xiaohei

赞同来自:

10205.jpg

节点名和端口号改过,其他的都没有改动;
觉得是哪里配置出问题了

要回复问题请先登录注册