ES5安装x-pack授权异常

新安装ES5,参照官方说明(https://www.elastic.co/downloads/x-pack)操作,到登录kibana页面时,显示没有lisence。
申请free lisence以后,安装密码密码文件,用x-pack默认密码elastic/changeme不能登录。
这个问题怎样解决,有人能指导?
 
已邀请:

Xargin

赞同来自: medcl glanms codepub

在elasticsearch.yml里加这么一行
 
xpack.security.enabled: false
 
这个设置项我竟然是猜出来,我都佩服我自己233

medcl - Elastic 🇨🇳 !

赞同来自: KevinShen

1.es和 kibana 都需要安装xpack插件
2.先启动 es,再启动 kibana
3.具体异常或截图发一下

dianond

赞同来自: wangohyes

在 kibana - plugins - x-pack 的 index.js 文件中
我把graph security都注释掉了,然后重启kibana,就好了,反正basic license也不能用它们

leighton_buaa

赞同来自: lbx6z

请问大家,我在es使用xpack时发现以下log,大概每隔10s出现一次,这是什么原因?
[2016-11-24T14:25:17,169][INFO ][o.e.x.m.e.Exporters      ] [SR067974CTI3700] skipping exporter [default_local] as it isn't ready yet
[2016-11-24T14:25:17,169][ERROR][o.e.x.m.AgentService ] [SR067974CTI3700] exception when exporting documents
org.elasticsearch.xpack.monitoring.exporter.ExportException: exporters are either not ready or faulty
at org.elasticsearch.xpack.monitoring.exporter.Exporters.export(Exporters.java:188) ~[x-pack-5.0.1.jar:5.0.1]
at org.elasticsearch.xpack.monitoring.AgentService$ExportingWorker.run(AgentService.java:208) [x-pack-5.0.1.jar:5.0.1]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_111]

wangohyes

赞同来自:

在哪申请的free lisence啊~没找到~

dianond

赞同来自:

我也是,安装后,系统提示
Your Basic license does not support Security. Please upgrade your license or disable Security in Elasticsearch.
要禁用Security,但是我不知道在哪里禁用
Elasticsearch访问的时候已经不出现登录验证了

dianond

赞同来自:

1.es和 kibana 都需要安装xpack插件
2.先启动 es,再启动 kibana
3.官网注册basic key
4.导入key
再重启后僵在那里了,不知道怎么禁用它的Security

wangohyes

赞同来自:

都收费……只能看看了~

kerwin - 90后挨踢男

赞同来自:

https://www.elastic.co/guide/e ... .html
官网了里这页讲,x-pack默认是启用全部功能的,可以按需要禁用功能,操蛋的是,小白在这里容易被坑,对,这个小白说的就是我。

zero

赞同来自:

我也被坑了,但是我爬起来了!!
 
其实先装es
再装kibana
再在es目录安装x-pack
kibana里面安装x-pack
 
这时可以在es里面更改elastic密码。。 ok

kerwin - 90后挨踢男

赞同来自:

先装es
再装kibana
再在es目录安装x-pack
kibana里面安装x-pack
在elasticsearch.yml中设置xpack.security.enabled: false
重启es
重启kibana
访问IP:9200,正常,告诉我去搜索。
访问IP:5601,页面不展示,浏览器上说重定向过多,
依据官网也在kibana.yml中配置了xpack.security.enabled: false,启动后端口都没有了,进程却在。
这应该怎么破,顺道问一下,rpm安装的kibana日志记录在哪里?

xinjingcheng

赞同来自:

@kerwin 你的问题解决了吗  我的问题和你一模一样  只是浏览器那里显示无法访问  其余的一样

ilangge

赞同来自:

我es和kibana都安装了x-pack,es启动正常,kibana启动报ssl连接错误,要求我配置公钥和私钥,必须走ssl,才能连接es,麻烦,先放着,后面再慢慢配置x-pack

要回复问题请先登录注册