我有点怀疑你在刷屏

使用search-guard之后如何使用elasticsearch-head连接集群?

Elasticsearch | 作者 JustRun | 发布于2017年09月15日 | 阅读数:5985

centos6.7
es5.5.2安装search-guard之后访问集群会需要输入用户名和密码, 这个时候如何使用elasticsearch-head连接集群?
已邀请:

JustRun - just run

赞同来自:

顶起。。。。。

xinfanwang

赞同来自:

用standalone方式启动head,浏览器用:http://localhost:9100/%3Fauth_ ... ngeme访问head.文档有说明的。

yumg

赞同来自:

如果以stand-alone模式来使用elasticsearch-head的话(用一个独立于ES的Web服务伺服elasticsearch-head),并且使用SearchGuard为ES开启Https以及Http Basic Auth的话,参见如下说明:

1、首先,确认Elasticsearch可以接受跨域的Ajax请求,在其配置文件中添加如下选项:

```
http.cors.enabled: true
http.cors.allow-origin: "*"
http.cors.allow-headers: Authorization
```

2、访问elasticsearch-head时,在URL上加上 auth_user 和 auth_password 参数,比如以下:


http:// localhost:9100/_plugin/head/?auth_user=admin&auth_password=admin

以上两个参数值,就是SearchGuard为ES添加的Http basic认证的用户名和密码。

3、在elasticsearch-head中,的elasticsearch连接地址处,填入https地址,比如以下:

https://127.0.0.1:9200/

注意是https协议头,之后就可以正常连接了。

null_Exception

赞同来自:

您好,我也碰到这个问题了,请问您解决了么?

create17

赞同来自:

修改elasticsearch.yml配置文件,添加:
 
http.cors.enabled: true
http.cors.allow-origin: "*"
http.cors.allow-headers: Authorization,X-Requested-With,Content-Length,Content-Type
 
然后,在浏览器上访问:http://ip:9100/%3Fauth_user%3D ... admin
在里面的输入框里面输入:https://ip:port/


1587984788.png

Ricky_Lau - 码农,,

赞同来自:

自己去修改源码加上证书,

lz8086 - es小司机

赞同来自:

查看head插件的github网址,上面有介绍

Young

赞同来自:

现在有解决方案了吗?

要回复问题请先登录注册