不要急,总有办法的

Elasticsearch 5.2.0启动后出现提示某节点[default_local]还没准备好

Elasticsearch | 作者 panku | 发布于2017年10月06日 | 阅读数:2072

报错:
[INFO] [o.e.x.m.e.Exporters] [node-1] skipping exporter [default_local] as it isn't ready yet
 
elasticsearch.yml配置如下:#主节点
cluster.name: my-application
node.name: node-0
node.master: true
path.data: /usr/local/elasticsearch-5.3.0/data
path.logs: /usr/local/elasticsearch-5.3.0/logs
bootstrap.memory_lock: false
bootstrap.system_call_filter: false
network.host: 0.0.0.0
http.port: 9200
transport.tcp.port: 9300
discovery.zen.ping.unicast.hosts: ["192.168.1.109:9300"]
node.max_local_storage_nodes: 2
http.cors.enabled: true
http.cors.allow-origin: "*"
已邀请:

kennywu76 - Wood

赞同来自: medcl

集群安装有xpack,其中的监控插件marvel需要配置一个exporter决定将监控数据写到哪里去。 默认没有配置情况下,写到本地集群,也就是default_local,所以需要确认集群状态是否正常(green),特别是报错的node-1这个结点是否在正常工作。
 
exporter的配置参考这个帖子: https://elasticsearch.cn/question/1915
 

要回复问题请先登录注册