elasticsearch-jdbc 同步数据出错

我下载elasticsearch版本是5.6.1的版本,elasticsearch-jdbc下载的是2.3.4.1版本,配置好后,同步数据报错:
java.lang.IllegalStateException: Received message from unsupported version: [2.0.0] minimal compatible version is: [5.0.0]
然后我查了下发elasticsearch-jdbc下面用的elasticsearch版本的是2.3.4的,所以有可能造成了这个原因,有解决办法吗?
已邀请:

laoyang360 - 博客:blog.csdn.net/laoyang360 微信公众号:铭毅天下

赞同来自:

是的,很有可能。
建议直接使用 logstash-input-jdbc了,5.xlogstash已经自带,不需要再单独安装。

zhaoyangwu

赞同来自:

我下载5.6.1这个版本的 logstash 怎么看是自带的,还只需要安装下这个插件啊

要回复问题请先登录注册