Hello,World

springboot整合elasticsearch6.0.0,项目启动时总是报错

Elasticsearch | 作者 newairisme | 发布于2017年11月21日 | 阅读数:7844

Caused by: java.lang.IllegalArgumentException: @ConditionalOnMissingBean annotations must specify at least one bean (type, name or annotation)
已邀请:

newairisme - 90后IT男

赞同来自:

我知道是版本问题 ,但是请教各位,pom.xml应该怎么配置呢?
<parent>
        <groupId>org.springframework.boot</groupId>
        <artifactId>spring-boot-starter-parent</artifactId>
        <version>1.3.1.RELEASE</version>  
    </parent>

           <repositories>
              <repository>
                 <id>elasticsearch-releases</id>
                 <url>https://artifacts.elastic.co/maven&lt;/url&gt;
                 <releases>
                    <enabled>true</enabled>
                 </releases>
                 <snapshots>
                    <enabled>false</enabled>
                 </snapshots>
              </repository>
           </repositories>
   
                <dependencies>
                    <dependency>  
                 <groupId>junit</groupId>  
                 <artifactId>junit</artifactId>  
                 <version>3.8.1</version>  
                 <scope>test</scope>  
               </dependency>  
                        <dependency>
                           <groupId>org.elasticsearch</groupId>
                           <artifactId>elasticsearch</artifactId>
                           <version>6.0.0</version>
                        </dependency>
                        <dependency>
                           <groupId>org.elasticsearch.client</groupId>
                           <artifactId>transport</artifactId>
                           <version>6.0.0</version>
                        </dependency>  
                        <dependency>
                           <groupId>org.elasticsearch.client</groupId>
                           <artifactId>x-pack-transport</artifactId>
                           <version>6.0.0</version>    
                        </dependency>
                        
                        <dependency>
                           <groupId>org.apache.logging.log4j</groupId>
                           <artifactId>log4j-api</artifactId>
                        </dependency>
                        
                        <dependency>   
                            <groupId>org.apache.logging.log4j</groupId>   
                            <artifactId>log4j-core</artifactId>
                        </dependency>
   <dependency>
       <groupId>org.springframework.boot</groupId>
       <artifactId>spring-boot-starter-data-elasticsearch</artifactId>
   </dependency>

bruceshan

赞同来自:

连接 es 跟 Spring 没有关系的,有restClient ,TransportClient 两种方式,前面使用 9200端口,后面使用  9300端口
 TransportClient :<dependency>
            <groupId>org.elasticsearch</groupId>
            <artifactId>elasticsearch</artifactId>
            <version>5.0.0</version>
        </dependency>
      <dependency>
          <groupId>org.elasticsearch.client</groupId>
          <artifactId>transport</artifactId>
          <version>5.0.0</version>
      </dependency>
 
restClient :

<!-- rest客户端 -->
<dependency>
    <groupId>org.elasticsearch.client</groupId>
    <artifactId>rest</artifactId>
    <version>5.5.1</version>
</dependency>
 

ZacReno - 90后大佬

赞同来自:

跟springboot有关系的,,你用的时候需要排除spring自带的es包,,pom文件里面

要回复问题请先登录注册