6.2.4elasticsearch安装时说jdk1.7版本过低,并且在启动脚本中没找到可以修改JAVA_HOME的地方,新手求解,谢谢!

已邀请:

yayg2008

赞同来自:

JAVA_HOME 是系统环境变量,一般在操作系统设置。ES只是从这个环境变量调用java

zqc0512 - andy zhou

赞同来自:

if [ ! -x "$JAVA" ]; then
    echo "Could not find any executable java binary. Please install java in your PATH or set JAVA_HOME"
    exit 1
fi
用户环境变量配置一个就行了。

shitangjiejie

赞同来自:

es最低版本要求jdk1.8
你装一个jdk1.8就行

要回复问题请先登录注册