本地编译启动es报奇怪的错怎么破

作者 God_lockin | 发布于2018年10月13日 | 阅读数:88

Mac,jdk11(openjdk),es master分支
根据这篇文章各种配(https://blog.csdn.net/wwwdc101 ... 78966
然后把官网642的包里面的module拷过来用的……
结果启动的时候发现出现这个错误:
[2018-10-13T19:57:21,545][INFO ][o.e.n.Node               ] [node-1] node name [node-1], node ID [zmbN8b6KR_SzV4HPENhOLg]
[2018-10-13T19:57:21,545][INFO ][o.e.n.Node ] [node-1] version[6.4.2-SNAPSHOT], pid[4408], build[unknown/unknown/Unknown/Unknown], OS[Mac OS X/10.13.6/x86_64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/11/11+28]
[2018-10-13T19:57:21,545][INFO ][o.e.n.Node ] [node-1] JVM arguments [-Des.path.conf=/Users/chenchen/Working/SourceCode/elasticsearch/home/config, -Des.path.home=/Users/chenchen/Working/SourceCode/elasticsearch/home, -Dpath.data=/Users/chenchen/Working/SourceCode/elasticsearch/home/data, -Djava.security.policy=/Users/chenchen/Working/SourceCode/elasticsearch/home/config/java.policy, -Dlog4j2.disable.jmx=true, -javaagent:/Applications/IntelliJ IDEA.app/Contents/lib/idea_rt.jar=63569:/Applications/IntelliJ IDEA.app/Contents/bin, -Dfile.encoding=UTF-8]
[2018-10-13T19:57:21,545][WARN ][o.e.n.Node ] [node-1] version [6.4.2-SNAPSHOT] is a pre-release version of Elasticsearch and is not suitable for production
[2018-10-13T19:57:22,405][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node-1] fatal error in thread [main], exiting
java.lang.NoClassDefFoundError: org/elasticsearch/action/GenericAction
at java.lang.Class.getDeclaredConstructors0(Native Method) ~[?:?]
at java.lang.Class.privateGetDeclaredConstructors(Class.java:3138) ~[?:?]
at java.lang.Class.getConstructors(Class.java:1944) ~[?:?]
at org.elasticsearch.plugins.PluginsService.loadPlugin(PluginsService.java:581) ~[main/:?]
at org.elasticsearch.plugins.PluginsService.loadBundle(PluginsService.java:549) ~[main/:?]
at org.elasticsearch.plugins.PluginsService.loadBundles(PluginsService.java:464) ~[main/:?]
at org.elasticsearch.plugins.PluginsService.<init>(PluginsService.java:156) ~[main/:?]

看起来像是某个插件不存在?在百度Google了一下也没看出个所以然来……
是不是应该用比如642之类的分支而不应该用master来编译启动?
已邀请:

要回复问题请先登录注册