Well,不要刷屏了

alpine构建elasticsearch6.0.1 节点之间无法通信

Elasticsearch | 作者 kindy | 发布于2018年11月05日 | 阅读数:879

# 配置文件
cluster.name: btr-test01
node.name: node-142
path.data: /home/apps/elasticsearch/data
path.logs: /home/apps/elasticsearch/logs
http.host: 172.16.16.142
http.port: 9200
transport.tcp.port: 9300
discovery.zen.ping.unicast.hosts: ["172.16.16.142:9200"]
http.cors.enabled: true
http.cors.allow-origin: "*"

TIM图片20181105171817.png

结果导致: 节点之间无法通过9300 进行正常通信! 
已邀请:

rochy - rochy_he

赞同来自: kindy

节点间无法通讯的原因应该是:discovery.zen.ping.unicast.hosts: ["172.16.16.142:9200"]
这里需要配置 9300 , 9200 是 HTTP 通讯端口

zqc0512 - andy zhou

赞同来自: kindy

discovery.zen.ping.unicast.hosts: ["172.16.16.142:9200"] 
这玩意master节点都要添加上……
 

kindy

赞同来自:

好的 

要回复问题请先登录注册