橡皮、老虎皮、狮子皮哪一个最不好?

elasticdump命令不识别中文 有米有地方可以设置

Elasticsearch | 作者 gyn_1004 | 发布于2020年01月14日 | 阅读数:147

在两台服务器上做数据迁移,用的elasticdump工具,索引名称中含有中文,迁移命令不支持。
命令:elasticdump --input http://...:9200/node_城市 --output http://...:9200/node_城市 --type=settings
错误:Error Emitted => Request path contains unescaped characters

但是在原服务上,索引是中文的没问题
已邀请:

Charele

赞同来自: gyn_1004

索引名中有中文没有关系吧。
你这个elasticdump是哪里的命令?
我的bin目录里没有这个命令啊,

dadaball

赞同来自:

我是沒有試過索引名稱用中文,如果不行的話,可以先用reindex 把索引名稱改成英文再用elasticdump把資料移過去。
移過去後再用reindex把索引改成中文
可以參考看看

juin - 大数据开发

赞同来自:

中文索引名进行下url 编码再试试??

要回复问题请先登录注册