即使是不成熟的尝试,也胜于胎死腹中的策略。

elasticsearch升级到7,kibana无法连接es

Elasticsearch | 作者 shitangjiejie | 发布于2020年04月23日 | 阅读数:9967

如下图,es集群已升级到7.6.2版本,查看集群状态已是健康状态
{
"cluster_name" : "ali-elk7",
"status" : "green",
"timed_out" : false,
"number_of_nodes" : 3,
"number_of_data_nodes" : 3,
"active_primary_shards" : 555,
"active_shards" : 1105,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 0,
"delayed_unassigned_shards" : 0,
"number_of_pending_tasks" : 0,
"number_of_in_flight_fetch" : 0,
"task_max_waiting_in_queue_millis" : 0,
"active_shards_percent_as_number" : 100.0
}
但是启动kibana,却报错:
log   [07:53:27.328] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_task_manager_1/W8BbgDSUS8GIqT31Uqxu8w] already exists, with { index_uuid="W8BbgDSUS8GIqT31Uqxu8w" & index=".kibana_task_manager_1" }
log [07:53:27.329] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_task_manager_1 and restarting Kibana.
log [07:53:27.339] [info][savedobjects-service] Creating index .kibana_1.
log [07:53:27.348] [warning][savedobjects-service] Unable to connect to Elasticsearch. Error: [resource_already_exists_exception] index [.kibana_1/jaYnxW3SRqyma0Ru_jnBEA] already exists, with { index_uuid="jaYnxW3SRqyma0Ru_jnBEA" & index=".kibana_1" }
log [07:53:27.349] [warning][savedobjects-service] Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_1 and restarting Kibana.
查看kibana配置没有可以肯定没有配置错误(曾尝试在es节点上安装kibana也尝试过)
server.port: 5601
server.host: "X.X.X.X"
elasticsearch.hosts: ["http://X.X.X.X:9200"]
kibana.index: ".kibana"
i18n.locale: "zh-CN"

elasticsearch版本是从6.4.2升级到7.6.2,kibana版本也是一样从6.4.2升级到7.6.2
尝试着照着日志里的报错信息把相关的索引进行删除后再重启kibana还是依然报相同错误,kibana节点访问es 9200端口也是正常能访问
这个问题真的已经困扰了我好久了,实在是想不出是啥原因导致,求各位大佬给指条明路
已邀请:

shitangjiejie

赞同来自:

可以了。。。

要回复问题请先登录注册