看,灰机...

metricbeat生成不了新的自定义index,配置改了很多条件,都没用

Beats | 作者 kitdeng | 发布于2020年05月07日 | 阅读数:287

metricbeat.config.modules:
path: ${path.config}/modules.d/*.yml
reload.enabled: false
reload.period: 10m



setup.dashboards.enabled: true

setup.ilm.enabled: true
setup.ilm.overwrite: true

setup.kibana:
host: "192.168.1.20:5601"

output.elasticsearch:
hosts: ["192.168.1.20:9200"]

output.elasticsearch.index: "testindex"
setup.template.enable: true
setup.template.name:"testindex"
setup.template.overwrite: true

setup.template.settings:
index.number_of_shards: 1
index.codec: best_compression

processors:
- add_host_metadata: ~
已邀请:

yesheng - 能认清自己吗?

赞同来自:

使用了setup.template要把ilm关掉。
1)setup.ilm.enabled: false
 
2)你配置文件中的这三行先注释掉。
setup.dashboards.enabled: true
setup.ilm.enabled: true
setup.ilm.overwrite: true
 
3)output.elasticsearch.index: "testindex"改为 setup.template.pattern:"testindex"
 
 
--可以参考: /etc/filebeat/filebeat.reference.yml
或者官网这里:https://www.elastic.co/guide/e ... .html

kitdeng - ELK应用者

赞同来自:

谢谢,我再测试一下

要回复问题请先登录注册