即使是不成熟的尝试,也胜于胎死腹中的策略。

filebeat设置多行合并不生效

Beats | 作者 xiao901231 | 发布于2021年11月11日 | 阅读数:1034

filebeat设置多行合并之后,kibana日志未合并,请查看附件配置,日志格式和kabana的日志
 
filebeat.inputs:
- type: log
  enabled: true
  paths:
    - /data/logs/tomcat/platform/default.log
  fields:
    source: platform
  #exclude_lines: ["^$"]

- type: log
  enabled: true
  paths:
    - /data/logs/tomcat/sales/default.log
  fields:
    source: sales
  #exclude_lines: ["^$"]

- type: log
  enabled: true
  paths:
    - /data/logs/tomcat/report/default.log
  fields:
    source: report
  #exclude_lines: ["^$"]

filebeat.config.modules:
  path: ${path.config}/modules.d/*.yml
  reload.enabled: true

multiline.pattern: '^[0-9]{4}-[0-9]{2}-[0-9]{2}'
multiline.negate: true
multiline.match: after
OU11N2K`8H[JRZKT5H0JS84.png S05~YD1BH(NBJ6JC@[1E_M.png
已邀请:

kin122

赞同来自:

检查一下,是不是yml格式问题。我记得是写在- type这段里面的。

要回复问题请先登录注册