愚者求师之过,智者从师之长。

急!求助各位高手,我的kafka客户端发消息到kafka总是在报“incorrect broker.version.fallback”,是什么原因啊?????????

默认分类 | 作者 yhacmilan | 发布于2017年12月20日 | 阅读数:4218

我的客户端向kafka发送消息时一直在报这个错:
Protocol parse failure at rd_kafka_produce_reply_handle:1954 (incorrect broker.version.fallback?),到处都查过了也解决不掉,有大神知道是什么问题吗?
设置的broker.version.fallback这个参数是0.8.2,但是改成什么值或者不设置都不行,安装的kafka是0.8.2.1版本
已邀请:

yhacmilan

赞同来自:

我的客户端用的是librdkafka

要回复问题请先登录注册