我有点怀疑你在刷屏

logstash 启动conf文件,没有写localhost 提示 Unreachable: [http://localhost:9200/]拒绝连接

Logstash | 作者 PhoebM | 发布于2018年03月20日 | 阅读数:4601

kibana和head都都是可以访问的,ip和端口没有问题,为什么连不上啊
Snap.jpg
input {
log4j {
host => "192.168.22.75"
port => 4560
}
}

output {
stdout {
codec => rubydebug
}
elasticsearch{
hosts => [ "192.168.22.95:9200","192.168.22.93:9200" ]
index => "log4j-%{+YYYY.MM.dd}"
}
}
已邀请:

hubble

赞同来自: PhoebM

是用了x-pack吗?如果是,试试在logstash.yml里加上下面两行:
 
xpack.monitoring.enabled: true 
xpack.monitoring.elasticsearch.url: http://X.X.X.X:9200
 
其中x.x.x.x是elasticsearch 集群的IP。

laoyang360 - Elastic认证工程师 [死磕Elasitcsearch]知识星球地址:http://t.cn/RmwM3N9;微信公众号:铭毅天下; 博客:https://elastic.blog.csdn.net

赞同来自:

es地址栏写一个地址试试

shitangjiejie

赞同来自:

看报错像是你logstash在启动的时候没有用你写的配置文件来启动

PhoebM - 生活很美好,万一被人误会肯定有自己的原因,受不了就解释,不想解释就看淡些,自己何苦为难自己

赞同来自:

Snap.jpg

 

要回复问题请先登录注册