在 Mapping 里面,将 dynamic 参数设置成 strict 可以拒绝索引包含未知字段的文档。 此条 Tips 由 medcl 贡献。

关于模板合并的问题

Elasticsearch | 作者 xiaohuojian | 发布于2016年03月30日 | 阅读数:2590

新增了一个模板:
{
"logstash-users": {
"order": 1,
"template": "logstash-users",
"settings": {
"index": {
"refresh_interval": "5s"
}
},
"mappings": {
"_default_": {
"dynamic_templates": [
{
"string_fields": {
"mapping": {
"fielddata": {
"format": "disabled"
},
"index": "not_analyzed",
"omit_norms": true,
"type": "string"
},
"match_mapping_type": "string",
"match": "*",
"fields": {
"raw": {
"ignore_above": 0
}
}
}
}
],
"_all": {
"enabled": false
}
}
},
"aliases": {}
}
}

在这个模板中设置"dynamic_templates": ["string_fields": {"fields": {"raw": {"ignore_above": 0……想去掉.raw字段,为何没法去掉?
已邀请:

要回复问题请先登录注册