Well,不要刷屏了

升级7.2后 max_shards_per_node 参数总是丢失

Elasticsearch | 作者 qq89267388 | 发布于2019年07月15日 | 阅读数:539

我的系统在升级7.2后 要求总的分片数不能超过3000

我通过下面的方式给他设置为了10000
PUT /_cluster/settings
{
"transient": {
"cluster": {
"max_shards_per_node":10000
}
}
}
 
然后logstash就可以正常写入了 ,但是这个参数总是丢失,所以每天都要重新设置一下
 
我想问的是 有什么拌饭能够将这个参数设置死不要总是调 要不然日志总会丢失
 
我尝试在elasticsearch.yml中增加了一个参数:cluster.routing.allocation.total_shards_per_node: 10000

但是没有效果
已邀请:

ridethewind

赞同来自:

transient 的参数是临时生效的,重启后丢失,
你把transient  ->  persistents试试

zqc0512 - andy zhou

赞同来自:

transient 临时
persistents 永久

qq89267388

赞同来自:

PUT /_cluster/settings
    {
      "persistents": {
        "cluster": {
          "max_shards_per_node":10000
        }
      }
    }
我用这个改完以后报错了
 
{
  "error": {
    "root_cause": [
      {
        "type": "action_request_validation_exception",
        "reason": "Validation Failed: 1: no settings to update;"
      }
    ],
    "type": "action_request_validation_exception",
    "reason": "Validation Failed: 1: no settings to update;"
  },
  "status": 400
}

zqc0512 - andy zhou

赞同来自:

      "persistents": {
change to
      "persistent": {
 

要回复问题请先登录注册