expression脚本条件更新

Elasticsearch | 作者 xshaw | 发布于2020年03月19日 | 阅读数:169

我现在尝试通过expression脚本去对于索引进行条件更新但现在返还了didn't store source的错误。请问有什么办法去修正呢?我现在用的是7.6的elasticsearch和kibana
expressionerror.PNG
已邀请:

liuxg - Elastic

赞同来自:

这里的语言应该是painless吧。你可以看一下在我的教程https://blog.csdn.net/UbuntuTo ... 81016里的例子。你直接搜一下_update_by_query
 
POST twitter/_update_by_query
{
  "script": {
    "source": "ctx._source.city = params.city;ctx._source.province = params.province;ctx._source.country = params.country",
    "lang": "painless",
    "params": {
      "city": "上海",
      "province": "上海",
      "country": "中国"
    },
    "query": {
      "match": {
        "user": "GB"
      }
    }
  }
}

要回复问题请先登录注册