在linux系统下安装完elasticsearch5以后,用curl也验证成功了,但是为什么远程访问不了,linux网络端口都没有问题

启动时控制台打印的如下:
 unable to load JNA native support library, native methods will be disabled.
e:/usr/chen/elasticsearch-5.5.2/lib/jopt-simple-5.0.2.jar, file:/usr/chen/elasticsearch-5.5.2/lib/java-version-checker-5.5.2.jar, file:/usr/chen/elasticsearch-5.5.2/lib/lucene-misc-6.6.0.jar])
        at com.sun.jna.Native.loadNativeDispatchLibraryFromClasspath(Native.java:962) ~[jna-4.4.0.jar:4.4.0 (b0)]
        at com.sun.jna.Native.loadNativeDispatchLibrary(Native.java:922) ~[jna-4.4.0.jar:4.4.0 (b0)]
        at com.sun.jna.Native.<clinit>(Native.java:190) ~[jna-4.4.0.jar:4.4.0 (b0)]
        at java.lang.Class.forName0(Native Method) ~[?:1.8.0_144]
        at java.lang.Class.forName(Class.java:264) ~[?:1.8.0_144]
        at org.elasticsearch.bootstrap.Natives.<clinit>(Natives.java:45) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Bootstrap.initializeNatives(Bootstrap.java:105) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Bootstrap.setup(Bootstrap.java:194) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.cli.Command.main(Command.java:88) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) [elasticsearch-5.5.2.jar:5.5.2]
        at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) [elasticsearch-5.5.2.jar:5.5.2]
[2017-08-18T10:45:35,870][WARN ][o.e.b.Natives            ] cannot check if running as root because JNA is not available
[2017-08-18T10:45:35,870][WARN ][o.e.b.Natives            ] cannot install system call filter because JNA is not available
[2017-08-18T10:45:35,873][WARN ][o.e.b.Natives            ] cannot register console handler because JNA is not available
[2017-08-18T10:45:35,884][WARN ][o.e.b.Natives            ] cannot getrlimit RLIMIT_NPROC because JNA is not available
[2017-08-18T10:45:35,908][WARN ][o.e.b.Natives            ] cannot getrlimit RLIMIT_AS beacuse JNA is not available
[2017-08-18T10:45:36,773][INFO ][o.e.n.Node               ] [] initializing ...
[2017-08-18T10:45:37,309][INFO ][o.e.e.NodeEnvironment    ] [u--eZfR] using [1] data paths, mounts [[/ (/dev/mapper/VolGroup-lv_root)]], net usable_space [4.3gb], net total_space [6.4gb], spins? [possibly], types [ext4]
[2017-08-18T10:45:37,309][INFO ][o.e.e.NodeEnvironment    ] [u--eZfR] heap size [1.9gb], compressed ordinary object pointers [unknown]
[2017-08-18T10:45:37,314][INFO ][o.e.n.Node               ] node name [u--eZfR] derived from node ID [u--eZfRpTlyqYMdxRAlw6Q]; set [node.name] to override
[2017-08-18T10:45:37,315][INFO ][o.e.n.Node               ] version[5.5.2], pid[2292], build[b2f0c09/2017-08-14T12:33:14.154Z], OS[Linux/2.6.32-573.el6.i686/i386], JVM[Oracle Corporation/Java HotSpot(TM) Server VM/1.8.0_144/25.144-b01]
[2017-08-18T10:45:37,317][INFO ][o.e.n.Node               ] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/usr/chen/elasticsearch-5.5.2]
[2017-08-18T10:45:40,626][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [aggs-matrix-stats]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [ingest-common]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [lang-expression]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [lang-groovy]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [lang-mustache]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [lang-painless]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [parent-join]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [percolator]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [reindex]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [transport-netty3]
[2017-08-18T10:45:40,627][INFO ][o.e.p.PluginsService     ] [u--eZfR] loaded module [transport-netty4]
[2017-08-18T10:45:40,629][INFO ][o.e.p.PluginsService     ] [u--eZfR] no plugins loaded
[2017-08-18T10:45:45,971][INFO ][o.e.d.DiscoveryModule    ] [u--eZfR] using discovery type [zen]
[2017-08-18T10:45:47,432][INFO ][o.e.n.Node               ] initialized
[2017-08-18T10:45:47,433][INFO ][o.e.n.Node               ] [u--eZfR] starting ...
[2017-08-18T10:45:47,845][INFO ][o.e.t.TransportService   ] [u--eZfR] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2017-08-18T10:45:47,894][WARN ][o.e.b.BootstrapChecks    ] [u--eZfR] max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]
[2017-08-18T10:45:47,895][WARN ][o.e.b.BootstrapChecks    ] [u--eZfR] max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2017-08-18T10:45:47,895][WARN ][o.e.b.BootstrapChecks    ] [u--eZfR] system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk
已邀请:

xinfanwang

赞同来自: xufeng_es jnuc093 Ticktoxavi

{127.0.0.1:9300}, 这个地址只能本机访问,换成实际IP地址或0.0.0.0。

wyntergreg

赞同来自:

selinux关了

ITxiaobing - IT小兵

赞同来自:

兄弟,把selinux关了和之前还是一样,还是不能远程访问
 

laoyang360 - [死磕Elasitcsearch]知识星球地址:http://t.cn/RmwM3N9;微信公众号:铭毅天下; 博客:blog.csdn.net/laoyang360

赞同来自:

防火墙关了试试

hagezhou

赞同来自:

你的配置文件里面, 就是那个yal,要把Ip:9200 打开

要回复问题请先登录注册