在 Mapping 里面,将 dynamic 参数设置成 strict 可以拒绝索引包含未知字段的文档。 此条 Tips 由 medcl 贡献。

filebeat的processor配置

Beats | 作者 woshixjian | 发布于2021年03月29日 | 阅读数:3302

本意是想在filebeat中配置业务信息,在搜索日志的时候可以在kibana中通过业务名称筛选,但是在filebeat中配置了- add_fields后,kibana中没有看到添加的字段,我的filebeat配置文件如下:
filebeat.inputs:
- type: log
enabled: true
paths:
- /var/log/messages
include_lines: ['ERR', 'err', 'Err', 'WARN', 'warn', 'Warn']
fields:
log_topic: messages
- type: log
enabled: true
paths:
- /var/log/audit/*.log
fields:
log_topic: audit
- type: log
enabled: true
paths:
- /var/log/kernal.log
fields:
log_topic: dmesg

processors:
- add_host_metadata:
netinfo.enabled: true
- add_fields:
fields:
product: ELK_system
module: ES_node03
问题解决了,最后发现是在-add_fields下的代码缩进问题,修改后:
- add_fields:
fields:
product: ELK_system
module: ES_node03

已邀请:

要回复问题请先登录注册