如何修改filebeat索引名称,配置index name没起作用

Beats | 作者 cxy | 发布于2019年07月07日 | 阅读数:433

按照官方文档配置了
setup.template.name: "custom"
setup.template.pattern: "
custom-*"
setup.template.enabled: false
output.elasticsearch.index: "custom-%{[agent.version]}-%{+yyyy.MM.dd}"
用es api创建了名为custom的template,但是启动filebeat 还是输出到了默认的filebeat索引里面去啊,这是怎么回事?难道必须要写fields.yml 文件然后指定吗?
已邀请:

bellengao - 博客: https://www.jianshu.com/u/e0088e3e2127

赞同来自: cxy

配置setup.ilm.enabled: false试试,索引生命周期管理ilm功能默认开启,开启的情况下索引名称只能为filebeat-*, 通过setup.ilm.enabled: false进行关闭;如果要使用自定义的索引名称,同时又需要启用ilm,可以修改filebeat的模板

要回复问题请先登录注册